Touit du Dimanche 8 Janvier 2017 à 15:50:25

La flemme de virer jquery d'un projet legacy te permet de te prendre la tête sur des trucs bien cons...
Un exemple vécu à l'instant: attacher un événement à un input, pas de soucis... sauf si on crée l'input après le chargement du js, auquel cas il faut utiliser .on()... oui, mais des fois ça marche pas parce qu'on sait pas pourquoi ! Il faut alors passer par un

$(document).on('click','.moy input[type=number]',function(){

du plus moche effet...


Donc, en résumé, on suit les étapes suivantes:

1- $('.moy input[type=number]').click(
2- $('.moy input[type=number]').on('click',function(){
3- $(document).on('click','.moy input[type=number]',function(){




Développeurs de Jquery, allez dans la paix du seigneur

Touit du Dimanche 1 Janvier 2017 à 17:56:26


Excellente année à tous malgré les élections qui approchent, les attentats un peu partout (courage aux turcs en ce moment, je pense à vous), la tendance qu'ont eu les stars de notre jeunesse à mourir trop tôt, les régressions sociales, les difficultés à lutter contre les oppressions, les dîners en famille avec les oncles racistes bref ! Malgré tous les empêcheurs de s'aimer en rond, en carré, tout droit ou de travers, que le cul se leur pèle et que cette nouvelle année soit celle des bonheurs inespérés comme 2016 a été celle des malheurs inattendus...

Je vous aime. Tous. (oui, même toi, là-bas)


Touit du Lundi 12 Décembre 2016 à 19:09:03

php 7 qui veut pas fonctionner avec Mint 18...

Après avoir écumé le ouaibe pour trouver des solutions, après avoir installé / désinstallé une grosse douzaines de fois LAMP, apache seul, php seul, libapache2-mod-php7.0 seul... J'ai fini par voir que libapache2-mod-php7.0 ne s'installait pas dans les mods d'apache2...

Du coup, j'ai téléchargé le deb, ouvert avec le gestionnaire d'archives et j'ai ajouté les fichiers conf et load au bon endroit... Et... ça marche...

Touit du Mardi 6 Décembre 2016 à 19:26:03

Dans la famille pas de bol, je voudrais le père... Pour mon deuxième test d'impression, l'alim de mon imprimante a fait poufcétout...


J'ai pris contact avec le vendeur et j'attends sa réponse, mais me voilà frustré dans mon élan.
Toutefois, j'ai eu une idée: et si l'alim d'un pc inutilisé avait le même voltage/ampérage que celle de l'imprimante ?


Ben apparemment, oui !



Donc, je raccorde deux fils, je teste la sortie pour voir, avant de brancher... Tout à l'air de baigner.
Je fais un branchement temporaire à mon imprimante et elle démarre !


Bon, alors:

  1. c'est bien l'alim qui merde
  2. cette alim peut faire l'affaire, à tester avec un tout petit objet.
  3. une alim dédiée, neuve coûte entre 30 et 50 €, au pire.


Fil RSS des articles de cette catégorie